Support #75

can ipcomman work with mpich1 through autotool on piglet?

Added by Ting Xie about 7 years ago. Updated about 7 years ago.

Status:ClosedStart date:09/10/2010
Priority:NormalDue date:
Assignee:Cameron Smith% Done:

0%

Category:-Spent time:-
Target version:-

Description

1. mpich1 on piglet does not have mpicxx option, which one should we use to compile .cc files?
2. we tried mpicc in /usr/local/mpich/latest/ch_p4/bin to compile ipcomman, and it failed because of some strange error.

History

#1 Updated by Cameron Smith about 7 years ago

  • Status changed from New to Closed

Building with the compiler wrappers of the MPICH1 installed at SCOREC, in the location you specified, will not be successful using the autoTools currently provided for IpComMan or FMDB. This is not a problem with the autoTools for those projects nor a incompatibility with MPICH1. The problem is that the C++ MPI compiler wrapper was not installed with MPICH1 on SCOREC.

It is possible to build IpComMan, FMDB, or any other project that uses autoTools with most MPI implementations. It requires that variables for the MPI include directories, library directories, libraries, compilation flags, linking flags and auxiliary libraries all be set manually. For setting these variables the SCOREC BuildUtil config files can be referred to.

If someone needs to do this I can work with them.

-Cameron

#2 Updated by Ben Matthews about 7 years ago

Unless things have changed, you're using the C bindings anyway so you should be able to scrape the output of mpicc -show and use that to build your c++ code with g++, but there's really no reason to support that. The lack of c++ bindings is purely for historical reasons (that build has been around longer than me). There's another build (which uses standard options but includes debug symbols) which also includes C++ bindings if you want to try mpich1 on rhel4 (though that should also be an obscure combination at this point) in /usr/local/mpich/1.2.7p1-debug (and other builds which include shared libraries or are build position independent, also in /usr/local/mpich, pick whichever version works)

Also available in: Atom PDF